直接 pip install pyinstaller==2.1 指定版本号就可以了

问题描述

今天要在一个低版本的python环境(2.6.6)下使用pyinstaller打包自己的应用,但是在使用pip安装pyinstaller之后发现打包报错,检查了一下环境是pyinstaller的版本太高(3.0),而此版本的pyinstaller支持的python版本是2.7.x。

解决办法

首先到PyInstaller的官网找低版本的PyInstaller(https://pypi.python.org/pypi/PyInstaller),发现两个文档版2.1和3.0。所以果断卸载3.0版本,安装2.1版本。

卸载3.0版本

pip uninstall pyinstaller

安装2.1版本

pip install https://pypi.python.org/packages/source/P/PyInstaller/PyInstaller-2.1.zip#md5=3eb18a454311707a

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注