先装了yum -y install openssl openssl-devel ncurses-devel.x86_64  bzip2-devel sqlite-devel python-devel zlib

然后pip install cx_Oracle就好了,也不知道到底是哪个依赖解决的。没装这些的时候一直pip install cx_Oracle安装报错

最终发现实际是装了这个python-devel包好的

Warning: RPMDB altered outside of yum.
Updating : python-2.6.6-66.el6_8.x86_64 1/5
Updating : python-libs-2.6.6-66.el6_8.x86_64 2/5
Installing : python-devel-2.6.6-66.el6_8.x86_64 3/5
Cleanup : python-2.6.6-51.el6.x86_64 4/5
Cleanup : python-libs-2.6.6-51.el6.x86_64 5/5
Verifying : python-devel-2.6.6-66.el6_8.x86_64 1/5
Verifying : python-libs-2.6.6-66.el6_8.x86_64 2/5
Verifying : python-2.6.6-66.el6_8.x86_64 3/5
Verifying : python-libs-2.6.6-51.el6.x86_64 4/5
Verifying : python-2.6.6-51.el6.x86_64

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注