今天在弄mjpeg-streamer的时候,由于没有安装jpeg库,就倒腾了一下。相到上次移植板子的时候,做过类似的工作,就拿着那个时候编译好的动态链接库放到我现在的/usr/lib/里面,当然出错啦,就和下面一样

“/usr/lib/libjpeg.so.62: ELF file OS ABI invalid”

ELF file OS ABI invalid

二进制级别不兼容,一般是两个东西,这才想起来两个的编译器不一样,一个是arm-linux-gcc 另外一个是gcc,由于第一次遇到,故记录下来,备查看!!
———————
作者:熊猫加油
来源:CSDN
原文:https://blog.csdn.net/xiongmaojiayou/article/details/7562296
版权声明:本文为博主原创文章,转载请附上博文链接!

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注